New Website with No Orders

Forum White Hat SEO New Website with No Orders

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #27159
    seohelper
    Keymaster

    Hello, we recently had our website made new. We were on a Joomla platform previous, then we moved to WordPress (same domain name). On the older website we would get somewhat consistent orders throughout the time. Ever since we have switched over to a new website we have had no customer orders. Is the reasoning behind this, all due to SEO, and having that established domain age? Thank you.

    #27160
    CriticalCentimeter

    unless you planned for the new site with someone who has SEO knowledge, you’ve probably not followed a proper migration path.

    AS such, youve probably lost all your previous ranking ;positions that generated your sales.

    #27162
    limerty

    Check your traffic. Is it way down?

    Check your 404s Any getting hit more than once or twice? Redirect them

    Is it local? Did you lose your GMB rankings?

    Not enough info to give any specific answers.

    Zero sales sounds like it could just be site straight up not working.

    #27164
    eventualist

    Yeah something is up especially if its an established site w resales

    #27163
    AndreDaressi

    Maybe the site is not as professional looking under WordPress as with Joomla.

    Any particular reason why you switched platforms rather than scaling?

    #27161
    warnakey

    Have you done test sales to confirm your shit is even working?

    #27165
    MacFG

    You managing the SEO or an external company? If so what did they have to say?

    #27166
    plaidmtnofrage

    Sounds like any Seo link juice was lost during the migration if the pages weren’t redirected. Also check if they were redirected that they are 301s.

    #27167
    tmac_79

    are your landing points all redirected to the new pages correctly? If the address changed, you have to get the traffic to the right spot.

    #27168
    Acceptable_Media7802

    301 them with yoast premium

    #27169
    mjdigitalmaster

    You need to check out all pages urls and redirection properly, also check your GSC and GA BING where property added it may be show some development related issues there. Also check schema markup and other important on-page factors. And check with your order booking plugin or third party Online application.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.
Scroll to Top