Please Help

Forum White Hat SEO PPC Please Help

  • This topic has 3 replies, 1 voice, and was last updated 1 month ago by No-Tangerine-4046.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #7016
    seohelper
    Keymaster

    Hey guys, it would be great to get someones help on this.

    Just launched my first campaign at a new job and having a couple issues.

    I’m having an issue with my Facebook dashboard. I launched a campaign yesterday optimizing for conversion and purchases. The problem I’m having is Facebook is showing me the campaign has delivered 4 website purchases, but I can only see the purchase value for 1.

    Another issue i am having is the purchase value that was tracked, is not displaying in Google analytics.

    I had set up UTM tracking, so not sure why this is the case?

    What could be wrong? Any help here would be amazing!

    #7017
    beyonce_trolls

    Is the pixel set up correctly?
    I’ve found that if the pixel conversion isn’t set up accurately it will report more purchases than have happened. If Google Analytics is set up correctly and it’s not showing the purchases, it’s likely the pixel is not set up correctly.

    #7018
    captnamazing

    Most likely there is a rogue purchase event sitting on some page. I’ve had this happen before. It was always due to a default Purchase event on some page I didn’t know about.

    #7019
    No-Tangerine-4046

    Hey u/captnamazing and u/beyonce_trolls

    ​

    Thank you for your help on this!

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.
Scroll to Top